Updating to Mojave 10.14.4 on an unsupported Apple hardware

I am running 10.14.3 on an unsupported Apple hardware. macOS 10.14.4 update showed up on the App Store Updates for quite a while now. I had the opportunity to update to 10.14.4 rather early this morning before skipping out for training. Popped by the mac couple times and before realising the mac hung after a reboot.

I relied on dosdude1’s Mojave Patcher as this mac hardware was no longer supported by Apple. I somehow skipped checking his page for the latest news on 10.14.4, and this turned around and hit me squarely in the face.

-> Dosdude1’s patcher page indicated the 1.30 patcher tool needs to be installed before updating to 10.14.4. <-

Drats! Training called and I had to leave. I was mulling over this problem and googling to no help – It is very no one tried updating to 10.14.4 WITHOUT dosdude1’s 1.30 patch.

Just not long ago, I bit the bullet and applied the 1.30 patch over the currently non-functioning partition. After 32 minutes and applying the dosdude1’s Post Install drivers, the mac booted up. [Hooray!]

I quickly ran a check and all seemed fine except 10.14.4 was not applied and the mac remained on 10.14.3.

I’ll keep the mac on 10.14.3 until this weekend.

Leave a Reply

Your email address will not be published.